5 cent hint – Xamarin and Your Java version (1.7.0) is too old error

By | 3. March 2017

If you get after Xamarin update building error

“Project  cannot build using Android 7.0 (API Level 24 – Nougat) because Your Java version (1.7.0) is too old. You must have at least 1.8 installed.
Please install it or set Java Development Kit path for Oracle 1.8+ on Tools->Options->Xamarin->Android Settings menu.”


  1. Install Java SDK version 8 if not already done
  2. Uninstall Java SDK version 7
  3. Clean project
  4.  Try rebuild

Worked for me.


Leave a Reply